Migration from earlier Versions

When you update Security Analyst to a new version you might have to migrate existing projects into the new format. If migration is necessary, the migrated project cannot be opened with the old versions any longer.

Migration from Versions 2019.2 and later

Projects created with Security Analyst 2019.2 and later are automatically migrated when opened in the latest version.

Migration from Versions 1.2.5 and later

If you open a project created with Security Analyst 1.2.5, 2019.2 and later it will be migrated automatically. However, in some cases you have to select “Ignore and Continue” for problems found by the Migration Assistant:

Migration Assistant Wizard: Migration in Progress

Migration Assistant Wizard: Migration in Progress

Please select “Stop Migration“ in the first place to learn more about detected problems. All found issues will be shown in the bottom-left corner of the main window:

Model Checker: Migration issues

Model Checker: Migration issues

If you only see problems of the type “unknown language feature” stating “Missing link: …” like in the screenshot above, you can safely ignore them. Just re-run the Migration Assistant from the main menu (Migration -> Run Migration Assistant) and select “Ignore and Continue”. As always, contact us for support on security-analyst@itemis.de if you need any help.

Migration from Version 1.2.4 and earlier

It is not possible to open projects created with Security Analyst 1.2.4 and earlier in Security Analyst 2019.2+. You will see the following dialog when opening such an old project:

Incompatible Model

Incompatible Model

In this case, please download Security Analyst 1.2.5 by clicking “Download Security Analyst 1.2.5 …”. Note that this download also includes an extended license. Then, open the project with the downloaded version and follow the Migration Assistant that pops up automatically. After the migration has completed you can open the project with the latest Version 2019.3.